Chrome 135 Now Live for DejaClick Monitors on Public Locations

Incident Report for AlertSite

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 27, 2026 - 12:26 UTC

Investigating

We’re pleased to inform you that Chrome 135 is now live for DejaClick monitors across all public locations. You can now start using Chrome 135 without any additional action required. This update ensures improved stability, performance, and alignment with the latest browser standards.
Chrome 135 will also be made available on Private Nodes soon.
If you experience any issues or have questions, please reach out to our support team.
Posted Apr 27, 2026 - 08:59 UTC